Cambio de versión predeterminada de PHP, de 5.3 a 5.4

A partir del 1 de Septiembre vamos a comenzar a modificar la versión predetermina de PHP en nuestros servidores de hosting.

Actualmente, en la mayoría de nuestros servidores, la versión predeterminada de PHP es la 5.3, lo que significa que una web usará PHP 5.3 a no ser que el cliente opte por usar otra versión.

Dado que 5.3 es la versión predeterminada, la mayoría de las webs alojadas con nosotros usan dicha versión. Pero la versión 5.3 ya es antigua y PHP dejará de ofrecer soporte en breve, por tanto, ya es hora de actualizarse.

¿Que vamos a hacer?

Vamos a poner 5.4 como la versión predeterminada de PHP, lo que hará que toda web que no haya seleccionado específicamente una versión de PHP concreta, pase a usar PHP 5.4.

Eso se traduce en que la mayoría de webs pasarán de usar PHP 5.3 a 5.4
La versión 5.4 de PHP es bastante compatible con 5.3, por tanto, la mayoría de webs funcionarán igual de bien con PHP 5.4. De hecho, la mayoría de webs funcionarán más rápido.

Desgraciadamente, habrá algunas webs que darán problemas con PHP 5.4, por lo que será necesario forzar el uso de PHP 5.3 en las mismas.

¿Que es lo que tienes que hacer?

La mayoría no tendréis que hacer nada, pero si crees que tu web necesita PHP 5.3 para funcionar y que dará problema con la versión 5.4, tienes que forzar el uso de PHP 5.3 .

Para hacerlo, no tienes más que añadir la siguiente línea en el archivo .htaccess de tu web:

Addhandler php5.3-script .php

Si no tienes claro como hacerlo, contacta con nosotros.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *